Back to overview
Power Issues
Jun 24 at 06:56pm IST
Affected services
Billing Area
Resolved
Jun 24 at 06:56pm IST
There is some power issues in the server we are currently dealing with it.
Affected services
Billing Area
Resolved
Jun 24 at 06:56pm IST
There is some power issues in the server we are currently dealing with it.
Affected services
Billing Area